[CANCELLED] React Poll Migration to v3

Bounty Request Format:

Discord Username Sasha#0007

Payment Information : free/minimal

Description of Cog: v2 to v3 React Poll that I had made a while ago via an outside coder. Would be free to all to use, as was a modified existing cog… preferably by an approved repo, so anyone that may find it helpful can trust it’s coding, as would offer it to be used for ‘RedBot’ Cogs generally, & not as a custom/private cog.
Thought I’d share it, as I have about 6 bots now, (2 Reds) but this may be useful for some.

V2 >> V3

My v2 Version on GitHub

The differences from the Original, was mainly it only uses the increments used ie: 1d, or hrs and so on, (one or more), if used when making a poll. ie: not all 00:00:00 different, also various tweaks to the ‘view’ of.

No takers? It was from Flapjack originally, but had it changed to use ‘other’ than seconds… ie: can use days/hours/minutes or combinations, inc seconds… will accept all types…

I’d offer 5$ + what @Sasha is up to.

Sounds good, so you want to add to my offer I take it…

Since found some screeshots of the cog, also showing differences to the one already available… ie: time input is not in seconds, has emojis alongside questions and time “countdown”/ poll ends in… is the input used only, therefore would be “ends in 1 day” or “6 hrs” ie: whatever time increment, input is used… not 100s of 1000s of seconds.

As shown, hope someone is interested.



There was a very large update/rewrite of reactpoll done by Trusty that was merged today. I specifically asked him to consider this request… you can find some new time parsing in his PR.

Thanks for letting me know. It looks good, have checked it out a bit… also like the new ‘multiple answer & the Interactive setting’

Though haven’t worked out how it works entirely, as in: when you stop entering options with the Interactive one… there’s no ‘key input’ direction to move on, it just 'ends poll creation based on timeout.

Hope he looks into using the emojis alongside also :thinking: edit: just worked it out, the Interactive one does it though… (you ‘type’ exit to finish…)